CVE-2022-40228

IBM DataPower Gateway 10.0.3.0 through 10.0.4.0, 10.0.1.0 through 10.0.1.9, 2018.4.1.0 through 2018.4.1.22, and 10.5.0.0 through 10.5.0.2 does not invalidate session after a password change which could allow an authenticated user to impersonate another user on the system. IBM X-Force ID: 235527.
References
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:ibm:datapower_gateway:*:*:*:*:*:*:*:*
cpe:2.3:a:ibm:datapower_gateway:*:*:*:*:*:*:*:*
cpe:2.3:a:ibm:datapower_gateway:*:*:*:*:*:*:*:*
cpe:2.3:a:ibm:datapower_gateway:*:*:*:*:*:*:*:*

History

26 Nov 2022, 03:30

Type Values Removed Values Added
CWE CWE-613
First Time Ibm
Ibm datapower Gateway
CVSS v2 : unknown
v3 : unknown
v2 : unknown
v3 : 5.4
CPE cpe:2.3:a:ibm:datapower_gateway:*:*:*:*:*:*:*:*
References (MISC) https://www.ibm.com/support/pages/node/6840759 - (MISC) https://www.ibm.com/support/pages/node/6840759 - Vendor Advisory
References (MISC) https://exchange.xforce.ibmcloud.com/vulnerabilities/235527 - (MISC) https://exchange.xforce.ibmcloud.com/vulnerabilities/235527 - VDB Entry, Vendor Advisory

22 Nov 2022, 19:17

Type Values Removed Values Added
New CVE

Information

Published : 2022-11-22 19:15

Updated : 2022-11-26 03:30


NVD link : CVE-2022-40228

Mitre link : CVE-2022-40228


JSON object : View

Products Affected

ibm

  • datapower_gateway
CWE
CWE-613

Insufficient Session Expiration