CVE-2022-40674

libexpat before 2.4.9 has a use-after-free in the doContent function in xmlparse.c.
References
Configurations

Configuration 1 (hide)

cpe:2.3:a:libexpat_project:libexpat:*:*:*:*:*:*:*:*

Configuration 2 (hide)

OR cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*
cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:*

History

29 Sep 2022, 17:15

Type Values Removed Values Added
References
  • (GENTOO) https://security.gentoo.org/glsa/202209-24 -

28 Sep 2022, 20:37

Type Values Removed Values Added
CPE cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*
cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:*
References (MLIST) https://lists.debian.org/debian-lts-announce/2022/09/msg00029.html - (MLIST) https://lists.debian.org/debian-lts-announce/2022/09/msg00029.html - Issue Tracking, Third Party Advisory
References (DEBIAN) https://www.debian.org/security/2022/dsa-5236 - (DEBIAN) https://www.debian.org/security/2022/dsa-5236 - Third Party Advisory
First Time Debian
Debian debian Linux

25 Sep 2022, 10:15

Type Values Removed Values Added
References
  • (MLIST) https://lists.debian.org/debian-lts-announce/2022/09/msg00029.html -

23 Sep 2022, 04:15

Type Values Removed Values Added
References
  • (DEBIAN) https://www.debian.org/security/2022/dsa-5236 -

16 Sep 2022, 03:09

Type Values Removed Values Added
CVSS v2 : unknown
v3 : unknown
v2 : unknown
v3 : 9.8
CWE CWE-416
First Time Libexpat Project
Libexpat Project libexpat
CPE cpe:2.3:a:libexpat_project:libexpat:*:*:*:*:*:*:*:*
References (MISC) https://github.com/libexpat/libexpat/pull/629 - (MISC) https://github.com/libexpat/libexpat/pull/629 - Issue Tracking, Patch, Third Party Advisory
References (MISC) https://github.com/libexpat/libexpat/pull/640 - (MISC) https://github.com/libexpat/libexpat/pull/640 - Issue Tracking, Patch, Third Party Advisory

14 Sep 2022, 11:15

Type Values Removed Values Added
New CVE

Information

Published : 2022-09-14 11:15

Updated : 2022-09-29 17:15


NVD link : CVE-2022-40674

Mitre link : CVE-2022-40674


JSON object : View

Products Affected

libexpat_project

  • libexpat

debian

  • debian_linux
CWE
CWE-416

Use After Free