CVE-2022-40752

IBM InfoSphere DataStage 11.7 is vulnerable to a command injection vulnerability due to improper neutralization of special elements. IBM X-Force ID:  236687.
References
Configurations

Configuration 1 (hide)

AND
OR cpe:2.3:a:ibm:infosphere_information_server:11.7:*:*:*:*:*:*:*
cpe:2.3:a:ibm:infosphere_information_server_on_cloud:11.7:*:*:*:*:*:*:*
OR cpe:2.3:o:ibm:aix:-:*:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:-:*:*:*:*:*:*:*
cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:*

History

23 Oct 2023, 18:15

Type Values Removed Values Added
Summary IBM InfoSphere DataStage 11.7 is vulnerable to a command injection vulnerability due to improper neutralization of special elements. IBM X-Force ID: 236687. IBM InfoSphere DataStage 11.7 is vulnerable to a command injection vulnerability due to improper neutralization of special elements. IBM X-Force ID:  236687.

20 Nov 2022, 13:23

Type Values Removed Values Added
CVSS v2 : unknown
v3 : unknown
v2 : unknown
v3 : 9.8
CWE CWE-77
First Time Ibm
Ibm aix
Linux
Linux linux Kernel
Microsoft windows
Microsoft
Ibm infosphere Information Server On Cloud
Ibm infosphere Information Server
CPE cpe:2.3:o:ibm:aix:-:*:*:*:*:*:*:*
cpe:2.3:a:ibm:infosphere_information_server:11.7:*:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:-:*:*:*:*:*:*:*
cpe:2.3:a:ibm:infosphere_information_server_on_cloud:11.7:*:*:*:*:*:*:*
cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:*
References (MISC) https://exchange.xforce.ibmcloud.com/vulnerabilities/236687 - (MISC) https://exchange.xforce.ibmcloud.com/vulnerabilities/236687 - VDB Entry, Vendor Advisory
References (MISC) https://www.ibm.com/support/pages/node/6833566 - (MISC) https://www.ibm.com/support/pages/node/6833566 - Patch, Vendor Advisory

16 Nov 2022, 23:15

Type Values Removed Values Added
New CVE

Information

Published : 2022-11-16 23:15

Updated : 2023-12-10 14:35


NVD link : CVE-2022-40752

Mitre link : CVE-2022-40752

CVE.ORG link : CVE-2022-40752


JSON object : View

Products Affected

ibm

  • infosphere_information_server
  • infosphere_information_server_on_cloud
  • aix

linux

  • linux_kernel

microsoft

  • windows
CWE
CWE-77

Improper Neutralization of Special Elements used in a Command ('Command Injection')