CVE-2022-41235

Jenkins WildFly Deployer Plugin 1.0.2 and earlier implements functionality that allows agent processes to read arbitrary files on the Jenkins controller file system.
Configurations

Configuration 1 (hide)

cpe:2.3:a:jenkins:wildfly_deployer:*:*:*:*:*:jenkins:*:*

History

22 Sep 2022, 16:09

Type Values Removed Values Added
CWE CWE-693 CWE-22
CVSS v2 : unknown
v3 : unknown
v2 : unknown
v3 : 5.3
References (CONFIRM) https://www.jenkins.io/security/advisory/2022-09-21/#SECURITY-2645 - (CONFIRM) https://www.jenkins.io/security/advisory/2022-09-21/#SECURITY-2645 - Vendor Advisory
First Time Jenkins
Jenkins wildfly Deployer
CPE cpe:2.3:a:jenkins:wildfly_deployer:*:*:*:*:*:jenkins:*:*

21 Sep 2022, 16:22

Type Values Removed Values Added
New CVE

Information

Published : 2022-09-21 16:15

Updated : 2022-09-22 16:09


NVD link : CVE-2022-41235

Mitre link : CVE-2022-41235


JSON object : View

Products Affected

jenkins

  • wildfly_deployer
CWE
CWE-22

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')