CVE-2022-41240

Jenkins Walti Plugin 1.0.1 and earlier does not escape the information provided by the Walti API, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to provide malicious API responses from Walti.
Configurations

Configuration 1 (hide)

cpe:2.3:a:jenkins:walti:*:*:*:*:*:jenkins:*:*

History

22 Sep 2022, 16:05

Type Values Removed Values Added
CVSS v2 : unknown
v3 : unknown
v2 : unknown
v3 : 5.4
First Time Jenkins
Jenkins walti
CPE cpe:2.3:a:jenkins:walti:*:*:*:*:*:jenkins:*:*
References (CONFIRM) https://www.jenkins.io/security/advisory/2022-09-21/#SECURITY-1870 - (CONFIRM) https://www.jenkins.io/security/advisory/2022-09-21/#SECURITY-1870 - Vendor Advisory

21 Sep 2022, 16:22

Type Values Removed Values Added
New CVE

Information

Published : 2022-09-21 16:15

Updated : 2022-09-22 16:05


NVD link : CVE-2022-41240

Mitre link : CVE-2022-41240


JSON object : View

Products Affected

jenkins

  • walti
CWE
CWE-79

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')