CVE-2022-41243

Jenkins SmallTest Plugin 1.0.4 and earlier does not perform hostname validation when connecting to the configured View26 server that could be abused using a man-in-the-middle attack to intercept these connections.
Configurations

Configuration 1 (hide)

cpe:2.3:a:jenkins:smalltest:*:*:*:*:*:jenkins:*:*

History

22 Sep 2022, 15:53

Type Values Removed Values Added
First Time Jenkins
Jenkins smalltest
CPE cpe:2.3:a:jenkins:smalltest:*:*:*:*:*:jenkins:*:*
References (CONFIRM) https://www.jenkins.io/security/advisory/2022-09-21/#SECURITY-2068 - (CONFIRM) https://www.jenkins.io/security/advisory/2022-09-21/#SECURITY-2068 - Vendor Advisory
CVSS v2 : unknown
v3 : unknown
v2 : unknown
v3 : 8.1

21 Sep 2022, 16:22

Type Values Removed Values Added
New CVE

Information

Published : 2022-09-21 16:15

Updated : 2022-09-22 15:53


NVD link : CVE-2022-41243

Mitre link : CVE-2022-41243


JSON object : View

Products Affected

jenkins

  • smalltest
CWE
CWE-297

Improper Validation of Certificate with Host Mismatch