CVE-2022-41940

Engine.IO is the implementation of transport-based cross-browser/cross-device bi-directional communication layer for Socket.IO. A specially crafted HTTP request can trigger an uncaught exception on the Engine.IO server, thus killing the Node.js process. This impacts all the users of the engine.io package, including those who uses depending packages like socket.io. There is no known workaround except upgrading to a safe version. There are patches for this issue released in versions 3.6.1 and 6.2.1.
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:socket:engine.io:*:*:*:*:*:node.js:*:*
cpe:2.3:a:socket:engine.io:*:*:*:*:*:node.js:*:*

History

26 Nov 2022, 03:26

Type Values Removed Values Added
References (MISC) https://github.com/socketio/engine.io/commit/83c4071af871fc188298d7d591e95670bf9f9085 - (MISC) https://github.com/socketio/engine.io/commit/83c4071af871fc188298d7d591e95670bf9f9085 - Patch, Third Party Advisory
References (MISC) https://github.com/socketio/engine.io/commit/425e833ab13373edf1dd5a0706f07100db14e3c6 - (MISC) https://github.com/socketio/engine.io/commit/425e833ab13373edf1dd5a0706f07100db14e3c6 - Patch, Third Party Advisory
References (CONFIRM) https://github.com/socketio/engine.io/security/advisories/GHSA-r7qp-cfhv-p84w - (CONFIRM) https://github.com/socketio/engine.io/security/advisories/GHSA-r7qp-cfhv-p84w - Exploit, Third Party Advisory
First Time Socket engine.io
Socket
CPE cpe:2.3:a:socket:engine.io:*:*:*:*:*:node.js:*:*
CVSS v2 : unknown
v3 : unknown
v2 : unknown
v3 : 6.5

22 Nov 2022, 13:44

Type Values Removed Values Added
New CVE

Information

Published : 2022-11-22 01:15

Updated : 2022-11-26 03:26


NVD link : CVE-2022-41940

Mitre link : CVE-2022-41940


JSON object : View

Products Affected

socket

  • engine.io
CWE
CWE-248

Uncaught Exception