CVE-2023-22731

Shopware is an open source commerce platform based on Symfony Framework and Vue js. In a Twig environment **without the Sandbox extension**, it is possible to refer to PHP functions in twig filters like `map`, `filter`, `sort`. This allows a template to call any global PHP function and thus execute arbitrary code. The attacker must have access to a Twig environment in order to exploit this vulnerability. This problem has been fixed with 6.4.18.1 with an override of the specified filters until the integration of the Sandbox extension has been finished. Users are advised to upgrade. Users of major versions 6.1, 6.2, and 6.3 may also receive this fix via a plugin.
Configurations

Configuration 1 (hide)

cpe:2.3:a:shopware:shopware:*:*:*:*:*:*:*:*

History

25 Jan 2023, 02:43

Type Values Removed Values Added
CPE cpe:2.3:a:shopware:shopware:*:*:*:*:*:*:*:*
First Time Shopware shopware
Shopware
References (MISC) https://github.com/shopware/platform/commit/89d1ea154689cb6202e0d3a0ceeae0febb0c09e1 - (MISC) https://github.com/shopware/platform/commit/89d1ea154689cb6202e0d3a0ceeae0febb0c09e1 - Patch, Third Party Advisory
References (MISC) https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-01-2023?category=security-updates - (MISC) https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-01-2023?category=security-updates - Patch, Vendor Advisory
References (MISC) https://github.com/shopware/platform/security/advisories/GHSA-93cw-f5jj-x85w - (MISC) https://github.com/shopware/platform/security/advisories/GHSA-93cw-f5jj-x85w - Third Party Advisory
CVSS v2 : unknown
v3 : unknown
v2 : unknown
v3 : 8.8

17 Jan 2023, 23:01

Type Values Removed Values Added
New CVE

Information

Published : 2023-01-17 22:15

Updated : 2023-01-25 02:43


NVD link : CVE-2023-22731

Mitre link : CVE-2023-22731


JSON object : View

Products Affected

shopware

  • shopware
CWE
CWE-94

Improper Control of Generation of Code ('Code Injection')