CVE-2023-35943

Envoy is an open source edge and service proxy designed for cloud-native applications. Prior to versions 1.27.0, 1.26.4, 1.25.9, 1.24.10, and 1.23.12, the CORS filter will segfault and crash Envoy when the `origin` header is removed and deleted between `decodeHeaders`and `encodeHeaders`. Versions 1.27.0, 1.26.4, 1.25.9, 1.24.10, and 1.23.12 have a fix for this issue. As a workaround, do not remove the `origin` header in the Envoy configuration.
References
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:envoyproxy:envoy:*:*:*:*:*:*:*:*
cpe:2.3:a:envoyproxy:envoy:*:*:*:*:*:*:*:*
cpe:2.3:a:envoyproxy:envoy:*:*:*:*:*:*:*:*
cpe:2.3:a:envoyproxy:envoy:*:*:*:*:*:*:*:*

History

02 Aug 2023, 18:47

Type Values Removed Values Added
First Time Envoyproxy envoy
Envoyproxy
CVSS v2 : unknown
v3 : unknown
v2 : unknown
v3 : 7.5
CPE cpe:2.3:a:envoyproxy:envoy:*:*:*:*:*:*:*:*
References (MISC) https://github.com/envoyproxy/envoy/security/advisories/GHSA-mc6h-6j9x-v3gq - (MISC) https://github.com/envoyproxy/envoy/security/advisories/GHSA-mc6h-6j9x-v3gq - Exploit, Third Party Advisory

25 Jul 2023, 19:15

Type Values Removed Values Added
New CVE

Information

Published : 2023-07-25 19:15

Updated : 2023-12-10 15:14


NVD link : CVE-2023-35943

Mitre link : CVE-2023-35943

CVE.ORG link : CVE-2023-35943


JSON object : View

Products Affected

envoyproxy

  • envoy
CWE
CWE-416

Use After Free