CVE-2023-36328

Integer Overflow vulnerability in mp_grow in libtom libtommath before commit beba892bc0d4e4ded4d667ab1d2a94f4d75109a9, allows attackers to execute arbitrary code and cause a denial of service (DoS).
Configurations

Configuration 1 (hide)

cpe:2.3:a:libtom:libtommath:*:*:*:*:*:*:*:*

Configuration 2 (hide)

cpe:2.3:o:fedoraproject:fedora:38:*:*:*:*:*:*:*

History

18 Sep 2023, 04:15

Type Values Removed Values Added
References
  • (FEDORA) https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/6ZUPWZGPFJ4JOI2NIP7YLRKZD5YXQTBK/ -
  • (FEDORA) https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/46GORAXZ34MHQNUGJBKS7PJ5NSMIAJGC/ -

06 Sep 2023, 00:05

Type Values Removed Values Added
References (FEDORA) https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/3H2PFUTBKQUDSOJXQQS7LUSZQWT3JTW2/ - (FEDORA) https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/3H2PFUTBKQUDSOJXQQS7LUSZQWT3JTW2/ - Mailing List
References (MISC) https://github.com/libtom/libtommath/pull/546 - (MISC) https://github.com/libtom/libtommath/pull/546 - Issue Tracking, Patch
CPE cpe:2.3:o:fedoraproject:fedora:38:*:*:*:*:*:*:*
cpe:2.3:a:libtom:libtommath:*:*:*:*:*:*:*:*
CVSS v2 : unknown
v3 : unknown
v2 : unknown
v3 : 9.8
First Time Libtom
Fedoraproject fedora
Fedoraproject
Libtom libtommath
CWE CWE-190

05 Sep 2023, 03:15

Type Values Removed Values Added
References
  • (FEDORA) https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/3H2PFUTBKQUDSOJXQQS7LUSZQWT3JTW2/ -

01 Sep 2023, 16:15

Type Values Removed Values Added
New CVE

Information

Published : 2023-09-01 16:15

Updated : 2023-09-18 04:15


NVD link : CVE-2023-36328

Mitre link : CVE-2023-36328

CVE.ORG link : CVE-2023-36328


JSON object : View

Products Affected

libtom

  • libtommath

fedoraproject

  • fedora
CWE
CWE-190

Integer Overflow or Wraparound