CVE-2023-46751

An issue was discovered in the function gdev_prn_open_printer_seekable() in Artifex Ghostscript through 10.02.0 allows remote attackers to crash the application via a dangling pointer.
Configurations

Configuration 1 (hide)

cpe:2.3:a:artifex:ghostscript:*:*:*:*:*:*:*:*

History

16 Dec 2023, 01:15

Type Values Removed Values Added
References
  • () https://www.debian.org/security/2023/dsa-5578 -

09 Dec 2023, 04:52

Type Values Removed Values Added
References () https://ghostscript.com/ - () https://ghostscript.com/ - Product
References () https://git.ghostscript.com/?p=ghostpdl.git%3Ba=commit%3Bh=dcdbc595c13c9d11d235702dff46bb74c80f7698 - () https://git.ghostscript.com/?p=ghostpdl.git%3Ba=commit%3Bh=dcdbc595c13c9d11d235702dff46bb74c80f7698 - Broken Link
References () https://bugs.ghostscript.com/show_bug.cgi?id=707264 - () https://bugs.ghostscript.com/show_bug.cgi?id=707264 - Permissions Required
CPE cpe:2.3:a:artifex:ghostscript:*:*:*:*:*:*:*:*
CVSS v2 : unknown
v3 : unknown
v2 : unknown
v3 : 7.5
CWE CWE-416
First Time Artifex ghostscript
Artifex

06 Dec 2023, 20:15

Type Values Removed Values Added
New CVE

Information

Published : 2023-12-06 20:15

Updated : 2023-12-16 01:15


NVD link : CVE-2023-46751

Mitre link : CVE-2023-46751

CVE.ORG link : CVE-2023-46751


JSON object : View

Products Affected

artifex

  • ghostscript
CWE
CWE-416

Use After Free