CVE-2024-1215

A vulnerability was found in SourceCodester CRUD without Page Reload 1.0. It has been rated as problematic. Affected by this issue is some unknown functionality of the file fetch_data.php. The manipulation of the argument username/city leads to cross site scripting. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. VDB-252782 is the identifier assigned to this vulnerability.
References
Link Resource
https://github.com/PrecursorYork/crud-without-refresh-reload-Reflected_XSS-POC/blob/main/README.md Exploit Third Party Advisory
https://vuldb.com/?ctiid.252782 Permissions Required Third Party Advisory
https://vuldb.com/?id.252782 Third Party Advisory
Configurations

Configuration 1 (hide)

cpe:2.3:a:crud_without_page_reload_project:crud_without_page_reload:1.0:*:*:*:*:*:*:*

History

12 Feb 2024, 19:32

Type Values Removed Values Added
Summary
  • (es) Se encontró una vulnerabilidad en SourceCodester CRUD sin Page Reload 1.0. Ha sido calificada como problemática. Una función desconocida del archivo fetch_data.php es afectada por esta vulnerabilidad. La manipulación del argumento nombre de usuario/ciudad conduce a Cross-Site Scripting. El ataque puede lanzarse de forma remota. El exploit ha sido divulgado al público y puede utilizarse. VDB-252782 es el identificador asignado a esta vulnerabilidad.
First Time Crud Without Page Reload Project crud Without Page Reload
Crud Without Page Reload Project
References () https://github.com/PrecursorYork/crud-without-refresh-reload-Reflected_XSS-POC/blob/main/README.md - () https://github.com/PrecursorYork/crud-without-refresh-reload-Reflected_XSS-POC/blob/main/README.md - Exploit, Third Party Advisory
References () https://vuldb.com/?ctiid.252782 - () https://vuldb.com/?ctiid.252782 - Permissions Required, Third Party Advisory
References () https://vuldb.com/?id.252782 - () https://vuldb.com/?id.252782 - Third Party Advisory
CVSS v2 : 4.0
v3 : 3.5
v2 : 4.0
v3 : 6.1
CPE cpe:2.3:a:crud_without_page_reload_project:crud_without_page_reload:1.0:*:*:*:*:*:*:*

03 Feb 2024, 16:16

Type Values Removed Values Added
New CVE

Information

Published : 2024-02-03 16:16

Updated : 2024-02-29 01:43


NVD link : CVE-2024-1215

Mitre link : CVE-2024-1215

CVE.ORG link : CVE-2024-1215


JSON object : View

Products Affected

crud_without_page_reload_project

  • crud_without_page_reload
CWE
CWE-79

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')