CVE-2024-23324

Envoy is a high-performance edge/middle/service proxy. External authentication can be bypassed by downstream connections. Downstream clients can force invalid gRPC requests to be sent to ext_authz, circumventing ext_authz checks when failure_mode_allow is set to true. This issue has been addressed in released 1.29.1, 1.28.1, 1.27.3, and 1.26.7. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:envoyproxy:envoy:*:*:*:*:*:*:*:*
cpe:2.3:a:envoyproxy:envoy:*:*:*:*:*:*:*:*
cpe:2.3:a:envoyproxy:envoy:*:*:*:*:*:*:*:*
cpe:2.3:a:envoyproxy:envoy:*:*:*:*:*:*:*:*

History

15 Feb 2024, 04:46

Type Values Removed Values Added
CVSS v2 : unknown
v3 : 8.6
v2 : unknown
v3 : 7.5
First Time Envoyproxy
Envoyproxy envoy
Summary
  • (es) Envoy es un proxy de servicio/intermedio/perimetral de alto rendimiento. La autenticación externa se puede omitir mediante conexiones descendentes. Los clientes intermedios pueden forzar el envío de solicitudes gRPC no válidas a ext_authz, eludiendo las comprobaciones de ext_authz cuando Failure_mode_allow se establece en verdadero. Este problema se solucionó en las versiones 1.29.1, 1.28.1, 1.27.3 y 1.26.7. Se recomienda a los usuarios que actualicen. No se conocen workarounds para esta vulnerabilidad.
CPE cpe:2.3:a:envoyproxy:envoy:*:*:*:*:*:*:*:*
CWE NVD-CWE-noinfo
References () https://github.com/envoyproxy/envoy/commit/29989f6cc8bfd8cd2ffcb7c42711eb02c7a5168a - () https://github.com/envoyproxy/envoy/commit/29989f6cc8bfd8cd2ffcb7c42711eb02c7a5168a - Patch, Vendor Advisory
References () https://github.com/envoyproxy/envoy/security/advisories/GHSA-gq3v-vvhj-96j6 - () https://github.com/envoyproxy/envoy/security/advisories/GHSA-gq3v-vvhj-96j6 - Vendor Advisory

09 Feb 2024, 23:15

Type Values Removed Values Added
New CVE

Information

Published : 2024-02-09 23:15

Updated : 2024-02-15 04:46


NVD link : CVE-2024-23324

Mitre link : CVE-2024-23324

CVE.ORG link : CVE-2024-23324


JSON object : View

Products Affected

envoyproxy

  • envoy
CWE
NVD-CWE-noinfo CWE-20

Improper Input Validation