CVE-2024-2879

The LayerSlider plugin for WordPress is vulnerable to SQL Injection via the ls_get_popup_markup action in versions 7.9.11 and 7.10.0 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:layerslider:layerslider:7.9.11:*:*:*:*:wordpress:*:*
cpe:2.3:a:layerslider:layerslider:7.10.0:*:*:*:*:wordpress:*:*

History

08 Apr 2024, 22:49

Type Values Removed Values Added
References () https://layerslider.com/release-log/ - () https://layerslider.com/release-log/ - Release Notes
References () https://www.wordfence.com/threat-intel/vulnerabilities/id/3fddf96e-029c-4753-ba82-043ca64b78d3?source=cve - () https://www.wordfence.com/threat-intel/vulnerabilities/id/3fddf96e-029c-4753-ba82-043ca64b78d3?source=cve - Third Party Advisory
CWE CWE-89
CPE cpe:2.3:a:layerslider:layerslider:7.10.0:*:*:*:*:wordpress:*:*
cpe:2.3:a:layerslider:layerslider:7.9.11:*:*:*:*:wordpress:*:*
CVSS v2 : unknown
v3 : 9.8
v2 : unknown
v3 : 7.5
First Time Layerslider layerslider
Layerslider

03 Apr 2024, 12:38

Type Values Removed Values Added
Summary
  • (es) El complemento LayerSlider para WordPress es vulnerable a la inyección SQL a través de la acción ls_get_popup_markup en las versiones 7.9.11 y 7.10.0 debido a un escape insuficiente en el parámetro proporcionado por el usuario y a la falta de preparación suficiente en la consulta SQL existente. Esto hace posible que atacantes no autenticados agreguen consultas SQL adicionales a consultas ya existentes que pueden usarse para extraer información confidencial de la base de datos.

03 Apr 2024, 04:15

Type Values Removed Values Added
New CVE

Information

Published : 2024-04-03 04:15

Updated : 2024-04-08 22:49


NVD link : CVE-2024-2879

Mitre link : CVE-2024-2879

CVE.ORG link : CVE-2024-2879


JSON object : View

Products Affected

layerslider

  • layerslider
CWE
CWE-89

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')