CVE-2024-32975

Envoy is a cloud-native, open source edge and service proxy. There is a crash at `QuicheDataReader::PeekVarInt62Length()`. It is caused by integer underflow in the `QuicStreamSequencerBuffer::PeekRegion()` implementation.
References
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:envoyproxy:envoy:*:*:*:*:*:*:*:*
cpe:2.3:a:envoyproxy:envoy:*:*:*:*:*:*:*:*
cpe:2.3:a:envoyproxy:envoy:*:*:*:*:*:*:*:*
cpe:2.3:a:envoyproxy:envoy:*:*:*:*:*:*:*:*

History

12 Jun 2024, 15:12

Type Values Removed Values Added
CVSS v2 : unknown
v3 : 5.9
v2 : unknown
v3 : 7.5
References () https://github.com/envoyproxy/envoy/security/advisories/GHSA-g9mq-6v96-cpqc - () https://github.com/envoyproxy/envoy/security/advisories/GHSA-g9mq-6v96-cpqc - Exploit, Third Party Advisory
First Time Envoyproxy
Envoyproxy envoy
CPE cpe:2.3:a:envoyproxy:envoy:*:*:*:*:*:*:*:*

05 Jun 2024, 12:53

Type Values Removed Values Added
Summary
  • (es) Envoy es un proxy de servicio y borde de código abierto, nativo de la nube. Hay un bloqueo en `QuicheDataReader::PeekVarInt62Length()`. Se debe a un desbordamiento insuficiente de enteros en la implementación de `QuicStreamSequencerBuffer::PeekRegion()`.

04 Jun 2024, 21:15

Type Values Removed Values Added
New CVE

Information

Published : 2024-06-04 21:15

Updated : 2024-06-12 15:12


NVD link : CVE-2024-32975

Mitre link : CVE-2024-32975

CVE.ORG link : CVE-2024-32975


JSON object : View

Products Affected

envoyproxy

  • envoy
CWE
CWE-191

Integer Underflow (Wrap or Wraparound)