Vulnerabilities (CVE)

Filtered by vendor Auth0 Subscribe
Filtered by product Lock
Total 4 CVE
CVE Vendors Products Updated CVSS v2 CVSS v3
CVE-2022-29172 1 Auth0 1 Lock 2022-05-16 2.6 LOW 6.1 MEDIUM
Auth0 is an authentication broker that supports both social and enterprise identity providers, including Active Directory, LDAP, Google Apps, and Salesforce. In versions before `11.33.0`, when the “additional signup fields� feature [is configured](https://github.com/auth0/lock#additional-sign-up-fields), a malicious actor can inject invalidated HTML code into these additional fields, which is then stored in the service `user_metdata` payload (using the `name` property). Verification emails, when applicable, are generated using this metadata. It is therefor possible for an actor to craft a malicious link by injecting HTML, which is then rendered as the recipient's name within the delivered email template. You are impacted by this vulnerability if you are using `auth0-lock` version `11.32.2` or lower and are using the “additional signup fields� feature in your application. Upgrade to version `11.33.0`.
CVE-2021-32641 1 Auth0 1 Lock 2021-06-16 4.3 MEDIUM 6.1 MEDIUM
auth0-lock is Auth0's signin solution. Versions of nauth0-lock before and including `11.30.0` are vulnerable to reflected XSS. An attacker can execute arbitrary code when the library's `flashMessage` feature is utilized and user input or data from URL parameters is incorporated into the `flashMessage` or the library's `languageDictionary` feature is utilized and user input or data from URL parameters is incorporated into the `languageDictionary`. The vulnerability is patched in version 11.30.1.
CVE-2020-15119 1 Auth0 1 Lock 2020-08-25 3.5 LOW 5.4 MEDIUM
In auth0-lock versions before and including 11.25.1, dangerouslySetInnerHTML is used to update the DOM. When dangerouslySetInnerHTML is used, the application and its users might be exposed to cross-site scripting (XSS) attacks.
CVE-2019-20174 1 Auth0 1 Lock 2020-02-05 4.3 MEDIUM 6.1 MEDIUM
Auth0 Lock before 11.21.0 allows XSS when additionalSignUpFields is used with an untrusted placeholder.