Vulnerabilities (CVE)

Filtered by vendor Clever-cloud Subscribe
Total 1 CVE
CVE Vendors Products Updated CVSS v2 CVSS v3
CVE-2022-31053 2 Biscuitsec, Clever-cloud 4 Biscuit-auth, Biscuit-go, Biscuit-haskell and 1 more 2023-01-25 7.5 HIGH 9.8 CRITICAL
Biscuit is an authentication and authorization token for microservices architectures. The Biscuit specification version 1 contains a vulnerable algorithm that allows malicious actors to forge valid ?-signatures. Such an attack would allow an attacker to create a token with any access level. The version 2 of the specification mandates a different algorithm than gamma signatures and as such is not affected by this vulnerability. The Biscuit implementations in Rust, Haskell, Go, Java and Javascript all have published versions following the v2 specification. There are no known workarounds for this issue.