Vulnerabilities (CVE)

Filtered by vendor Iterm2 Subscribe
Filtered by product Iterm2
Total 3 CVE
CVE Vendors Products Updated CVSS v2 CVSS v3
CVE-2019-19022 1 Iterm2 1 Iterm2 2019-11-19 5.0 MEDIUM 7.5 HIGH
iTerm2 through 3.3.6 has potentially insufficient documentation about the presence of search history in com.googlecode.iterm2.plist, which might allow remote attackers to obtain sensitive information, as demonstrated by searching for the NoSyncSearchHistory string in .plist files within public Git repositories.
CVE-2019-9535 1 Iterm2 1 Iterm2 2019-10-16 10.0 HIGH 9.8 CRITICAL
A vulnerability exists in the way that iTerm2 integrates with tmux's control mode, which may allow an attacker to execute arbitrary commands by providing malicious output to the terminal. This affects versions of iTerm2 up to and including 3.3.5. This vulnerability may allow an attacker to execute arbitrary commands on their victim's computer by providing malicious output to the terminal. It could be exploited using command-line utilities that print attacker-controlled content.
CVE-2015-9231 1 Iterm2 1 Iterm2 2017-10-05 5.0 MEDIUM 7.5 HIGH
iTerm2 3.x before 3.1.1 allows remote attackers to discover passwords by reading DNS queries. A new (default) feature was added to iTerm2 version 3.0.0 (and unreleased 2.9.x versions such as 2.9.20150717) that resulted in a potential information disclosure. In an attempt to see whether the text under the cursor (or selected text) was a URL, the text would be sent as an unencrypted DNS query. This has the potential to result in passwords and other sensitive information being sent in cleartext without the user being aware.