Vulnerabilities (CVE)

Filtered by vendor Jenkins Subscribe
Filtered by product Cons3rt
Total 4 CVE
CVE Vendors Products Updated CVSS v2 CVSS v3
CVE-2022-41255 1 Jenkins 1 Cons3rt 2022-09-22 N/A 6.5 MEDIUM
Jenkins CONS3RT Plugin 1.0.0 and earlier stores Cons3rt API token unencrypted in job config.xml files on the Jenkins controller where it can be viewed by users with access to the Jenkins controller file system.
CVE-2022-41254 1 Jenkins 1 Cons3rt 2022-09-22 N/A 6.5 MEDIUM
Missing permission checks in Jenkins CONS3RT Plugin 1.0.0 and earlier allow attackers with Overall/Read permission to connect to an attacker-specified HTTP server using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.
CVE-2022-41253 1 Jenkins 1 Cons3rt 2022-09-22 N/A 8.8 HIGH
A cross-site request forgery (CSRF) vulnerability in Jenkins CONS3RT Plugin 1.0.0 and earlier allows attackers to connect to an attacker-specified HTTP server using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.
CVE-2022-41252 1 Jenkins 1 Cons3rt 2022-09-22 N/A 4.3 MEDIUM
Missing permission checks in Jenkins CONS3RT Plugin 1.0.0 and earlier allows users with Overall/Read permission to enumerate credentials ID of credentials stored in Jenkins.