Vulnerabilities (CVE)

Filtered by vendor Lua Subscribe
Filtered by product Lua
Total 15 CVE
CVE Vendors Products Updated CVSS v2 CVSS v3
CVE-2021-32921 4 Debian, Fedoraproject, Lua and 1 more 4 Debian Linux, Fedora, Lua and 1 more 2022-05-16 4.3 MEDIUM 5.9 MEDIUM
An issue was discovered in Prosody before 0.11.9. It does not use a constant-time algorithm for comparing certain secret strings when running under Lua 5.2 or later. This can potentially be used in a timing attack to reveal the contents of secret strings to an attacker.
CVE-2021-44647 2 Fedoraproject, Lua 2 Fedora, Lua 2022-05-13 2.1 LOW 5.5 MEDIUM
Lua v5.4.3 and above are affected by SEGV by type confusion in funcnamefromcode function in ldebug.c which can cause a local denial of service.
CVE-2021-43519 2 Fedoraproject, Lua 2 Fedora, Lua 2022-05-03 4.3 MEDIUM 5.5 MEDIUM
Stack overflow in lua_resume of ldo.c in Lua Interpreter 5.1.0~5.4.4 allows attackers to perform a Denial of Service via a crafted script file.
CVE-2022-28805 1 Lua 1 Lua 2022-04-14 6.4 MEDIUM 9.1 CRITICAL
singlevar in lparser.c in Lua through 5.4.4 lacks a certain luaK_exp2anyregup call, leading to a heap-based buffer over-read that might affect a system that compiles untrusted Lua code.
CVE-2021-44964 1 Lua 1 Lua 2022-03-21 4.3 MEDIUM 6.3 MEDIUM
Use after free in garbage collector and finalizer of lgc.c in Lua interpreter 5.4.0~5.4.3 allows attackers to perform Sandbox Escape via a crafted script file.
CVE-2020-15888 1 Lua 1 Lua 2021-07-21 6.8 MEDIUM 8.8 HIGH
Lua through 5.4.0 mishandles the interaction between stack resizes and garbage collection, leading to a heap-based buffer overflow, heap-based buffer over-read, or use-after-free.
CVE-2021-32918 4 Debian, Fedoraproject, Lua and 1 more 4 Debian Linux, Fedora, Lua and 1 more 2021-05-26 5.0 MEDIUM 7.5 HIGH
An issue was discovered in Prosody before 0.11.9. Default settings are susceptible to remote unauthenticated denial-of-service (DoS) attacks via memory exhaustion when running under Lua 5.2 or Lua 5.3.
CVE-2020-24342 2 Fedoraproject, Lua 2 Fedora, Lua 2021-01-26 6.8 MEDIUM 7.8 HIGH
Lua through 5.4.0 allows a stack redzone cross in luaO_pushvfstring because a protection mechanism wrongly calls luaD_callnoyield twice in a row.
CVE-2020-15889 1 Lua 1 Lua 2020-12-23 7.5 HIGH 9.8 CRITICAL
Lua 5.4.0 has a getobjname heap-based buffer over-read because youngcollection in lgc.c uses markold for an insufficient number of list members.
CVE-2020-24371 1 Lua 1 Lua 2020-09-30 5.0 MEDIUM 5.3 MEDIUM
lgc.c in Lua 5.4.0 mishandles the interaction between barriers and the sweep phase, leading to a memory access violation involving collectgarbage.
CVE-2020-24370 1 Lua 1 Lua 2020-09-26 5.0 MEDIUM 5.3 MEDIUM
ldebug.c in Lua 5.4.0 allows a negation overflow and segmentation fault in getlocal and setlocal, as demonstrated by getlocal(3,2^31).
CVE-2020-24369 1 Lua 1 Lua 2020-08-24 5.0 MEDIUM 7.5 HIGH
ldebug.c in Lua 5.4.0 attempts to access debug information via the line hook of a stripped function, leading to a NULL pointer dereference.
CVE-2020-15945 1 Lua 1 Lua 2020-08-11 2.1 LOW 5.5 MEDIUM
Lua through 5.4.0 has a segmentation fault in changedline in ldebug.c (e.g., when called by luaG_traceexec) because it incorrectly expects that an oldpc value is always updated upon a return of the flow of control to a function.
CVE-2019-6706 2 Canonical, Lua 2 Ubuntu Linux, Lua 2019-11-06 5.0 MEDIUM 7.5 HIGH
Lua 5.3.5 has a use-after-free in lua_upvaluejoin in lapi.c. For example, a crash outcome might be achieved by an attacker who is able to trigger a debug.upvaluejoin call in which the arguments have certain relationships.
CVE-2014-5461 5 Canonical, Debian, Lua and 2 more 5 Ubuntu Linux, Debian Linux, Lua and 2 more 2018-10-30 5.0 MEDIUM N/A
Buffer overflow in the vararg functions in ldo.c in Lua 5.1 through 5.2.x before 5.2.3 allows context-dependent attackers to cause a denial of service (crash) via a small number of arguments to a function with a large number of fixed arguments.