Vulnerabilities (CVE)

Filtered by vendor Squirrel-lang Subscribe
Total 2 CVE
CVE Vendors Products Updated CVSS v2 CVSS v3
CVE-2022-30292 2 Fedoraproject, Squirrel-lang 2 Fedora, Squirrel 2022-08-10 7.5 HIGH 10.0 CRITICAL
Heap-based buffer overflow in sqbaselib.cpp in SQUIRREL 3.2 due to lack of a certain sq_reservestack call.
CVE-2021-41556 1 Squirrel-lang 1 Squirrel 2022-08-10 N/A 10.0 CRITICAL
sqclass.cpp in Squirrel through 2.2.5 and 3.x through 3.1 allows an out-of-bounds read (in the core interpreter) that can lead to Code Execution. If a victim executes an attacker-controlled squirrel script, it is possible for the attacker to break out of the squirrel script sandbox even if all dangerous functionality such as File System functions has been disabled. An attacker might abuse this bug to target (for example) Cloud services that allow customization via SquirrelScripts, or distribute malware through video games that embed a Squirrel Engine.