Vulnerabilities (CVE)

Filtered by CWE-94
Total 3151 CVE
CVE Vendors Products Updated CVSS v2 CVSS v3
CVE-2023-6996 1 Vegacorp 1 Display Custom Fields In The Frontend - Post And User Profile Fields 2024-02-13 N/A 8.8 HIGH
The Display custom fields in the frontend – Post and User Profile Fields plugin for WordPress is vulnerable to Code Injection via the plugin's vg_display_data shortcode in all versions up to, and including, 1.2.1 due to insufficient input validation and restriction on access to that shortcode. This makes it possible for authenticated attackers with contributor-level and above permissions to call arbitrary functions and execute code.
CVE-2024-22131 2024-02-13 N/A 9.1 CRITICAL
In SAP ABA (Application Basis) - versions 700, 701, 702, 731, 740, 750, 751, 752, 75C, 75I, an attacker authenticated as a user with a remote execution authorization can use a vulnerable interface. This allows the attacker to use the interface to invoke an application function to perform actions which they would not normally be permitted to perform.  Depending on the function executed, the attack can read or modify any user/business data and can make the entire system unavailable.
CVE-2023-6851 1 Kodcloud 1 Kodexplorer 2024-02-13 6.5 MEDIUM 9.8 CRITICAL
A vulnerability was found in kalcaddle KodExplorer up to 4.51.03. It has been rated as critical. This issue affects the function unzipList of the file plugins/zipView/app.php of the component ZIP Archive Handler. The manipulation leads to code injection. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 4.52.01 is able to address this issue. The patch is named 5cf233f7556b442100cf67b5e92d57ceabb126c6. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-248219.
CVE-2023-5677 1 Axis 22 M3024-lve, M3024-lve Firmware, M3025-ve and 19 more 2024-02-13 N/A 8.8 HIGH
Brandon Rothel from QED Secure Solutions has found that the VAPIX API tcptest.cgi did not have a sufficient input validation allowing for a possible remote code execution. This flaw can only be exploited after authenticating with an operator- or administrator-privileged service account. The impact of exploiting this vulnerability is lower with operator-privileges compared to administrator-privileges service accounts. Axis has released patched AXIS OS versions for the highlighted flaw. Please refer to the Axis security advisory for more information and solution.
CVE-2023-5800 1 Axis 3 Axis Os, Axis Os 2020, Axis Os 2022 2024-02-13 N/A 8.8 HIGH
Vintage, member of the AXIS OS Bug Bounty Program, has found that the VAPIX API create_overlay.cgi did not have a sufficient input validation allowing for a possible remote code execution. This flaw can only be exploited after authenticating with an operator- or administrator-privileged service account. Axis has released patched AXIS OS versions for the highlighted flaw. Please refer to the Axis security advisory for more information and solution.
CVE-2024-25110 2024-02-12 N/A 9.8 CRITICAL
The UAMQP is a general purpose C library for AMQP 1.0. During a call to open_get_offered_capabilities, a memory allocation may fail causing a use-after-free issue and if a client called it during connection communication it may cause a remote code execution. Users are advised to update the submodule with commit `30865c9c`. There are no known workarounds for this vulnerability.
CVE-2023-45735 1 Westermo 2 L206-f2g, L206-f2g Firmware 2024-02-12 N/A 8.0 HIGH
A potential attacker with access to the Westermo Lynx device may be able to execute malicious code that could affect the correct functioning of the device.
CVE-2023-50488 1 Blurams 2 Lumi Security Camera A31c, Lumi Security Camera A31c Firmware 2024-02-10 N/A 9.8 CRITICAL
An issue in Blurams Lumi Security Camera (A31C) v23.0406.435.4120 allows attackers to execute arbitrary code.
CVE-2023-51820 1 Blurams 2 Lumi Security Camera A31c, Lumi Security Camera A31c Firmware 2024-02-10 N/A 6.8 MEDIUM
An issue in Blurams Lumi Security Camera (A31C) v.2.3.38.12558 allows a physically proximate attackers to execute arbitrary code.
CVE-2024-23746 2 Apple, Miro 2 Macos, Miro 2024-02-10 N/A 9.8 CRITICAL
Miro Desktop 0.8.18 on macOS allows Electron code injection.
CVE-2024-22533 1 Xiandafu 1 Beetl 2024-02-10 N/A 9.8 CRITICAL
Before Beetl v3.15.12, the rendering template has a server-side template injection (SSTI) vulnerability. When the incoming template is controllable, it will be filtered by the DefaultNativeSecurityManager blacklist. Because blacklist filtering is not strict, the blacklist can be bypassed, leading to arbitrary code execution.
CVE-2021-22282 1 Br-automation 1 Automation Studio 2024-02-10 N/A 7.8 HIGH
Improper Control of Generation of Code ('Code Injection') vulnerability in B&R Industrial Automation Automation Studio allows Local Execution of Code.This issue affects Automation Studio: from 4.0 through 4.12.
CVE-2024-1117 1 Openbi 1 Openbi 2024-02-09 7.5 HIGH 9.8 CRITICAL
A vulnerability was found in openBI up to 1.0.8. It has been declared as critical. Affected by this vulnerability is the function index of the file /application/index/controller/Screen.php. The manipulation of the argument fileurl leads to code injection. The attack can be launched remotely. The exploit has been disclosed to the public and may be used. The associated identifier of this vulnerability is VDB-252475.
CVE-2024-0325 1 Perforce 1 Helix Sync 2024-02-09 N/A 7.8 HIGH
In Helix Sync versions prior to 2024.1, a local command injection was identified. Reported by Bryan Riggins.  
CVE-2024-0196 1 Ssssssss 1 Magic-api 2024-02-09 6.5 MEDIUM 8.8 HIGH
A vulnerability has been found in Magic-Api up to 2.0.1 and classified as critical. Affected by this vulnerability is an unknown functionality of the file /resource/file/api/save?auto=1. The manipulation leads to code injection. The attack can be launched remotely. The exploit has been disclosed to the public and may be used. The associated identifier of this vulnerability is VDB-249511.
CVE-2024-0195 1 Ssssssss 1 Spider-flow 2024-02-09 6.5 MEDIUM 9.8 CRITICAL
A vulnerability, which was classified as critical, was found in spider-flow 0.4.3. Affected is the function FunctionService.saveFunction of the file src/main/java/org/spiderflow/controller/FunctionController.java. The manipulation leads to code injection. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. VDB-249510 is the identifier assigned to this vulnerability.
CVE-2024-21649 1 Vantage6 1 Vantage6 2024-02-08 N/A 8.8 HIGH
The vantage6 technology enables to manage and deploy privacy enhancing technologies like Federated Learning (FL) and Multi-Party Computation (MPC). Prior to 4.2.0, authenticated users could inject code into algorithm environment variables, resulting in remote code execution. This vulnerability is patched in 4.2.0.
CVE-2023-37518 1 Hcltech 1 Bigfix Servicenow Data Flow 2024-02-05 N/A 8.8 HIGH
HCL BigFix ServiceNow is vulnerable to arbitrary code injection. A malicious authorized attacker could inject arbitrary code and execute within the context of the running user.
CVE-2024-1015 1 Se-elektronicgmbh 2 E-ddc3.3, E-ddc3.3 Firmware 2024-02-02 N/A 9.8 CRITICAL
Remote command execution vulnerability in SE-elektronic GmbH E-DDC3.3 affecting versions 03.07.03 and higher. An attacker could send different commands from the operating system to the system via the web configuration functionality of the device.
CVE-2023-37466 1 Vm2 Project 1 Vm2 2024-02-01 N/A 10.0 CRITICAL
vm2 is an advanced vm/sandbox for Node.js. The library contains critical security issues and should not be used for production. The maintenance of the project has been discontinued. In vm2 for versions up to 3.9.19, `Promise` handler sanitization can be bypassed with the `@@species` accessor property allowing attackers to escape the sandbox and run arbitrary code, potentially allowing remote code execution inside the context of vm2 sandbox.