Vulnerabilities (CVE)

Filtered by vendor Apache Subscribe
Filtered by product Soap
Total 2 CVE
CVE Vendors Products Updated CVSS v2 CVSS v3
CVE-2022-45378 1 Apache 1 Soap 2024-07-03 N/A 9.8 CRITICAL
In the default configuration of Apache SOAP, an RPCRouterServlet is available without authentication. This gives an attacker the possibility to invoke methods on the classpath that meet certain criteria. Depending on what classes are available on the classpath this might even lead to arbitrary remote code execution. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.
CVE-2022-40705 1 Apache 1 Soap 2024-05-17 N/A 7.5 HIGH
An Improper Restriction of XML External Entity Reference vulnerability in RPCRouterServlet of Apache SOAP allows an attacker to read arbitrary files over HTTP. This issue affects Apache SOAP version 2.2 and later versions. It is unknown whether previous versions are also affected. NOTE: This vulnerability only affects products that are no longer supported by the maintainer