Vulnerabilities (CVE)

Filtered by vendor Codepeople Subscribe
Total 37 CVE
CVE Vendors Products Updated CVSS v2 CVSS v3
CVE-2024-36082 1 Codepeople 1 Music Store 2024-07-17 N/A 6.5 MEDIUM
SQL injection vulnerability in Music Store - WordPress eCommerce versions prior to 1.1.14 allows a remote authenticated attacker with an administrative privilege to execute arbitrary SQL commands. Information stored in the database may be obtained or altered by the attacker.
CVE-2024-35735 1 Codepeople 1 Wp Time Slots Booking Form 2024-06-12 N/A 9.8 CRITICAL
Missing Authorization vulnerability in CodePeople WP Time Slots Booking Form.This issue affects WP Time Slots Booking Form: from n/a through 1.2.11.
CVE-2015-10099 1 Codepeople 1 Cp Appointment Calendar 2024-05-17 6.5 MEDIUM 9.8 CRITICAL
A vulnerability classified as critical has been found in CP Appointment Calendar Plugin up to 1.1.5 on WordPress. This affects the function dex_process_ready_to_go_appointment of the file dex_appointments.php. The manipulation of the argument itemnumber leads to sql injection. It is possible to initiate the attack remotely. The patch is named e29a9cdbcb0f37d887dd302a05b9e8bf213da01d. It is recommended to apply a patch to fix this issue. The associated identifier of this vulnerability is VDB-225351.
CVE-2014-125091 1 Codepeople 1 Polls Cp 2024-05-17 5.8 MEDIUM 9.8 CRITICAL
A vulnerability has been found in codepeople cp-polls Plugin 1.0.1 on WordPress and classified as critical. This vulnerability affects unknown code of the file cp-admin-int-message-list.inc.php. The manipulation of the argument lu leads to sql injection. The attack can be initiated remotely. Upgrading to version 1.0.2 is able to address this issue. The name of the patch is 6d7168cbf12d1c183bacc5cd5678f6f5b0d518d2. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-222268.
CVE-2024-31302 1 Codepeople 1 Contact Form Email 2024-04-26 N/A 5.3 MEDIUM
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in CodePeople Contact Form Email.This issue affects Contact Form Email: from n/a through 1.3.44.
CVE-2024-0963 1 Codepeople 1 Calculated Fields Form 2024-02-08 N/A 5.4 MEDIUM
The Calculated Fields Form plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's CP_CALCULATED_FIELDS shortcode in all versions up to, and including, 1.2.52 due to insufficient input sanitization and output escaping on user supplied 'location' attribute. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
CVE-2022-41790 1 Codepeople 1 Wp Time Slots Booking Form 2024-01-24 N/A 8.8 HIGH
Missing Authorization vulnerability in CodePeople WP Time Slots Booking Form.This issue affects WP Time Slots Booking Form: from n/a through 1.1.76.
CVE-2023-0389 1 Codepeople 1 Calculated Fields Form 2024-01-22 N/A 4.8 MEDIUM
The Calculated Fields Form WordPress plugin before 1.1.151 does not sanitise and escape some of its form settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
CVE-2023-51517 1 Codepeople 1 Calculated Fields Form 2024-01-05 N/A 5.4 MEDIUM
URL Redirection to Untrusted Site ('Open Redirect') vulnerability in CodePeople Calculated Fields Form.This issue affects Calculated Fields Form: from n/a through 1.2.28.
CVE-2023-5955 1 Codepeople 1 Contact Form Email 2023-12-13 N/A 4.8 MEDIUM
The Contact Form Email WordPress plugin before 1.3.44 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
CVE-2023-23971 1 Codepeople 1 Wp Time Slots Booking Form 2023-12-10 N/A 4.8 MEDIUM
Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in CodePeople WP Time Slots Booking Form plugin <= 1.1.81 versions.
CVE-2023-2718 1 Codepeople 1 Contact Form Email 2023-12-10 N/A 5.4 MEDIUM
The Contact Form Email WordPress plugin before 1.3.38 does not escape submitted values before displaying them in the HTML, leading to a Stored XSS vulnerability.
CVE-2022-43482 1 Codepeople 1 Appointment Booking Calendar 2023-12-10 N/A 8.8 HIGH
Missing Authorization vulnerability in Appointment Booking Calendar plugin <= 1.3.69 on WordPress.
CVE-2022-2567 1 Codepeople 1 Form Builder Cp 2023-12-10 N/A 4.8 MEDIUM
The Form Builder CP WordPress plugin before 1.2.32 does not sanitise and escape some of its form settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
CVE-2022-0389 1 Codepeople 1 Wp Time Slots Booking Form 2023-12-10 3.5 LOW 4.8 MEDIUM
The WP Time Slots Booking Form WordPress plugin before 1.1.63 does not sanitise and escape Calendar names, allowing high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
CVE-2021-42361 1 Codepeople 1 Contact Form Email 2023-12-10 2.1 LOW 4.8 MEDIUM
The Contact Form Email WordPress plugin is vulnerable to Stored Cross-Site Scripting due to insufficient input validation and escaping via the name parameter found in the ~/trunk/cp-admin-int-list.inc.php file which allowed attackers with administrative user access to inject arbitrary web scripts, in versions up to and including 1.3.24. This affects multi-site installations where unfiltered_html is disabled for administrators, and sites where unfiltered_html is disabled.
CVE-2020-7228 1 Codepeople 1 Calculated Fields Form 2023-12-10 3.5 LOW 5.4 MEDIUM
The Calculated Fields Form plugin through 1.0.353 for WordPress suffers from multiple Stored XSS vulnerabilities present in the input forms. These can be exploited by an authenticated user.
CVE-2020-9371 1 Codepeople 1 Appointment Booking Calendar 2023-12-10 3.5 LOW 4.8 MEDIUM
Stored XSS exists in the Appointment Booking Calendar plugin before 1.3.35 for WordPress. In the cpabc_appointments.php file, the Calendar Name input could allow attackers to inject arbitrary JavaScript or HTML.
CVE-2020-9372 1 Codepeople 1 Appointment Booking Calendar 2023-12-10 6.8 MEDIUM 7.8 HIGH
The Appointment Booking Calendar plugin before 1.3.35 for WordPress allows user input (in fields such as Description or Name) in any booking form to be any formula, which then could be exported via the Bookings list tab in /wp-admin/admin.php?page=cpabc_appointments.php. The attacker could achieve remote code execution via CSV injection.
CVE-2018-20964 1 Codepeople 1 Contact Form Email 2023-12-10 6.8 MEDIUM 8.8 HIGH
The contact-form-to-email plugin before 1.2.66 for WordPress has CSRF.