Vulnerabilities (CVE)

Filtered by vendor Icegram Subscribe
Total 27 CVE
CVE Vendors Products Updated CVSS v2 CVSS v3
CVE-2024-4295 1 Icegram 1 Email Subscribers \& Newsletters 2024-06-11 N/A 9.8 CRITICAL
The Email Subscribers by Icegram Express plugin for WordPress is vulnerable to SQL Injection via the ‘hash’ parameter in all versions up to, and including, 5.7.20 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
CVE-2023-51532 1 Icegram 1 Icegram Engage 2024-02-06 N/A 5.4 MEDIUM
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Icegram Icegram Engage – WordPress Lead Generation, Popup Builder, CTA, Optins and Email List Building allows Stored XSS.This issue affects Icegram Engage – WordPress Lead Generation, Popup Builder, CTA, Optins and Email List Building: from n/a through 3.1.19.
CVE-2023-52119 1 Icegram 1 Icegram Engage 2024-01-11 N/A 8.8 HIGH
Cross-Site Request Forgery (CSRF) vulnerability in Icegram Icegram Engage – WordPress Lead Generation, Popup Builder, CTA, Optins and Email List Building.This issue affects Icegram Engage – WordPress Lead Generation, Popup Builder, CTA, Optins and Email List Building: from n/a through 3.1.18.
CVE-2021-36832 1 Icegram 1 Icegram Engage 2024-01-10 3.5 LOW 5.4 MEDIUM
WordPress Popups, Welcome Bar, Optins and Lead Generation Plugin – Icegram (versions <= 2.0.2) vulnerable at "Headline" (&message_data[16][headline]) input.
CVE-2016-10963 1 Icegram 1 Icegram Engage 2024-01-10 4.3 MEDIUM 6.1 MEDIUM
The icegram plugin before 1.9.19 for WordPress has XSS.
CVE-2016-10962 1 Icegram 1 Icegram Engage 2024-01-10 4.3 MEDIUM 6.5 MEDIUM
The icegram plugin before 1.9.19 for WordPress has CSRF via the wp-admin/edit.php option_name parameter.
CVE-2019-15830 1 Icegram 1 Icegram Engage 2024-01-10 3.5 LOW 5.4 MEDIUM
The icegram plugin before 1.10.29 for WordPress has ig_cat_list XSS.
CVE-2022-45810 1 Icegram 1 Icegram Express 2023-12-10 N/A 9.8 CRITICAL
Improper Neutralization of Formula Elements in a CSV File vulnerability in Icegram Icegram Express – Email Marketing, Newsletters and Automation for WordPress & WooCommerce.This issue affects Icegram Express – Email Marketing, Newsletters and Automation for WordPress & WooCommerce: from n/a through 5.5.2.
CVE-2023-5414 1 Icegram 1 Icegram Express 2023-12-10 N/A 7.2 HIGH
The Icegram Express plugin for WordPress is vulnerable to Directory Traversal in versions up to, and including, 5.6.23 via the show_es_logs function. This allows administrator-level attackers to read the contents of arbitrary files on the server, which can contain sensitive information including those belonging to other sites, for example in shared hosting environments.
CVE-2023-25024 1 Icegram 1 Icegram Collect 2023-12-10 N/A 4.8 MEDIUM
Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in Icegram Icegram Collect plugin <= 1.3.8 versions.
CVE-2023-2398 1 Icegram 1 Icegram Engage 2023-12-10 N/A 6.1 MEDIUM
The Icegram Engage WordPress plugin before 3.1.12 does not escape a parameter before outputting it back in an attribute, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin
CVE-2022-3981 1 Icegram 1 Email Subscribers \& Newsletters 2023-12-10 N/A 8.8 HIGH
The Icegram Express WordPress plugin before 5.5.1 does not properly sanitise and escape a parameter before using it in a SQL statement, leading to a SQL injection exploitable by any authenticated users, such as subscriber
CVE-2022-0439 1 Icegram 1 Email Subscribers \& Newsletters 2023-12-10 6.5 MEDIUM 8.8 HIGH
The Email Subscribers & Newsletters WordPress plugin before 5.3.2 does not correctly escape the `order` and `orderby` parameters to the `ajax_fetch_report_list` action, making it vulnerable to blind SQL injection attacks by users with roles as low as Subscriber. Further, it does not have any CSRF protection in place for the action, allowing an attacker to trick any logged in user to perform the action by clicking a link.
CVE-2022-1776 1 Icegram 1 Popups\, Welcome Bar\, Optins And Lead Generation Plugin 2023-12-10 3.5 LOW 5.4 MEDIUM
The Popups, Welcome Bar, Optins and Lead Generation Plugin WordPress plugin before 2.1.8 does not sanitize and escape some campaign parameters, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks
CVE-2021-24941 1 Icegram 1 Icegram 2023-12-10 4.3 MEDIUM 6.1 MEDIUM
The Popups, Welcome Bar, Optins and Lead Generation Plugin WordPress plugin before 2.0.5 does not sanitise and escape the message_id parameter of the get_message_action_row AJAX action before outputting it back in an attribute, leading to a reflected Cross-Site Scripting issue
CVE-2020-5780 1 Icegram 1 Email Subscribers \& Newsletters 2023-12-10 5.0 MEDIUM 5.3 MEDIUM
Missing Authentication for Critical Function in Icegram Email Subscribers & Newsletters Plugin for WordPress prior to version 4.5.6 allows a remote, unauthenticated attacker to conduct unauthenticated email forgery/spoofing.
CVE-2020-5768 1 Icegram 1 Email Subscribers \& Newsletters 2023-12-10 4.0 MEDIUM 4.9 MEDIUM
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') in Icegram Email Subscribers & Newsletters Plugin for WordPress v4.4.8 allows a remote, authenticated attacker to determine the value of database fields.
CVE-2020-5767 1 Icegram 1 Email Subscribers \& Newsletters 2023-12-10 4.3 MEDIUM 6.5 MEDIUM
Cross-site request forgery in Icegram Email Subscribers & Newsletters Plugin for WordPress v4.4.8 allows a remote attacker to send forged emails by tricking legitimate users into clicking a crafted link.
CVE-2019-19984 1 Icegram 1 Email Subscribers \& Newsletters 2023-12-10 6.5 MEDIUM 6.3 MEDIUM
The WordPress plugin, Email Subscribers & Newsletters, before 4.2.3 had a flaw that allowed users with edit_post capabilities to manage plugin settings and email campaigns.
CVE-2019-19980 1 Icegram 1 Email Subscribers \& Newsletters 2023-12-10 4.0 MEDIUM 4.3 MEDIUM
The WordPress plugin, Email Subscribers & Newsletters, before 4.2.3 had a privilege bypass flaw that allowed authenticated users (Subscriber or greater access) to send test emails from the administrative dashboard on behalf of an administrator. This occurs because the plugin registers a wp_ajax function to send_test_email.