Vulnerabilities (CVE)

Filtered by vendor Ultimatemember Subscribe
Filtered by product Ultimate Member
Total 22 CVE
CVE Vendors Products Updated CVSS v2 CVSS v3
CVE-2022-1208 1 Ultimatemember 1 Ultimate Member 2022-06-17 3.5 LOW 5.4 MEDIUM
The Ultimate Member plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Biography field featured on individual user profile pages due to insufficient input sanitization and output escaping that allows users to encode malicious web scripts with HTML encoding that is reflected back on the page. This affects versions up to, and including, 2.3.2. Please note this issue was partially fixed in version 2.3.2 then subsequently fully patched in version 2.3.3.
CVE-2022-1209 1 Ultimatemember 1 Ultimate Member 2022-05-16 3.5 LOW 5.4 MEDIUM
The Ultimate Member plugin for WordPress is vulnerable to open redirects due to insufficient validation on supplied URLs in the social fields of the Profile Page, which makes it possible for attackers to redirect unsuspecting victims in versions up to, and including, 2.3.1 granted the victim clicks on a social icon on a user's profile page.
CVE-2020-36157 1 Ultimatemember 1 Ultimate Member 2021-07-21 7.5 HIGH 9.8 CRITICAL
An issue was discovered in the Ultimate Member plugin before 2.1.12 for WordPress, aka Unauthenticated Privilege Escalation via User Roles. Due to the lack of filtering on the role parameter that could be supplied during the registration process, an attacker could supply the role parameter with a WordPress capability (or any custom Ultimate Member role) and effectively be granted those privileges.
CVE-2021-24306 1 Ultimatemember 1 Ultimate Member 2021-06-03 3.5 LOW 5.4 MEDIUM
The Ultimate Member – User Profile, User Registration, Login & Membership Plugin WordPress plugin before 2.1.20 did not properly sanitise, validate or encode the query string when generating a link to edit user's own profile, leading to an authenticated reflected Cross-Site Scripting issue. Knowledge of the targeted username is required to exploit this, and attackers would then need to make the related logged in user open a malicious link.
CVE-2020-36170 1 Ultimatemember 1 Ultimate Member 2021-01-08 5.0 MEDIUM 5.3 MEDIUM
The Ultimate Member plugin before 2.1.13 for WordPress mishandles hidden name="timestamp" fields in forms.
CVE-2020-36156 1 Ultimatemember 1 Ultimate Member 2021-01-08 6.5 MEDIUM 8.8 HIGH
An issue was discovered in the Ultimate Member plugin before 2.1.12 for WordPress, aka Authenticated Privilege Escalation via Profile Update. Any user with wp-admin access to the profile.php page could supply the parameter um-role with a value set to any role (e.g., Administrator) during a profile update, and effectively escalate their privileges.
CVE-2020-36155 1 Ultimatemember 1 Ultimate Member 2021-01-07 7.5 HIGH 9.8 CRITICAL
An issue was discovered in the Ultimate Member plugin before 2.1.12 for WordPress, aka Unauthenticated Privilege Escalation via User Meta. An attacker could supply an array parameter for sensitive metadata, such as the wp_capabilities user meta that defines a user's role. During the registration process, submitted registration details were passed to the update_profile function, and any metadata was accepted, e.g., wp_capabilities[administrator] for Administrator access.
CVE-2019-10271 1 Ultimatemember 1 Ultimate Member 2020-08-24 4.0 MEDIUM 4.3 MEDIUM
An issue was discovered in the Ultimate Member plugin 2.39 for WordPress. It allows unauthorized profile and cover picture modification. It is possible to modify the profile and cover picture of any user once one is connected. One can also modify the profiles and cover pictures of privileged users. To perform such a modification, one first needs to (for example) intercept an upload-picture request and modify the user_id parameter.
CVE-2019-10673 1 Ultimatemember 1 Ultimate Member 2020-03-16 9.3 HIGH 8.8 HIGH
A CSRF vulnerability in a logged-in user's profile edit form in the Ultimate Member plugin before 2.0.40 for WordPress allows attackers to become admin and subsequently extract sensitive information and execute arbitrary code. This occurs because the attacker can change the e-mail address in the administrator profile, and then the attacker is able to reset the administrator password using the WordPress "password forget" form.
CVE-2015-9304 1 Ultimatemember 1 Ultimate Member 2020-03-09 4.3 MEDIUM 6.1 MEDIUM
The ultimate-member plugin before 1.3.18 for WordPress has XSS via text input.
CVE-2020-6859 1 Ultimatemember 1 Ultimate Member 2020-01-22 5.0 MEDIUM 5.3 MEDIUM
Multiple Insecure Direct Object Reference vulnerabilities in includes/core/class-files.php in the Ultimate Member plugin through 2.1.2 for WordPress allow remote attackers to change other users' profiles and cover photos via a modified user_id parameter. This is related to ajax_image_upload and ajax_resize_image.
CVE-2018-20965 1 Ultimatemember 1 Ultimate Member 2019-11-20 4.3 MEDIUM 6.1 MEDIUM
The ultimate-member plugin before 2.0.4 for WordPress has XSS.
CVE-2018-0585 1 Ultimatemember 1 Ultimate Member 2019-11-20 3.5 LOW 5.4 MEDIUM
Cross-site scripting vulnerability in Ultimate Member plugin prior to version 2.0.4 for WordPress allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
CVE-2018-13136 1 Ultimatemember 1 Ultimate Member 2019-09-18 4.3 MEDIUM 6.1 MEDIUM
The Ultimate Member (aka ultimatemember) plugin before 2.0.18 for WordPress has XSS via the wp-admin settings screen.
CVE-2018-17866 1 Ultimatemember 1 Ultimate Member 2019-09-03 4.3 MEDIUM 6.1 MEDIUM
Multiple cross-site scripting (XSS) vulnerabilities in includes/core/um-actions-login.php in the "Ultimate Member - User Profile & Membership" plugin before 2.0.28 for WordPress allow remote attackers to inject arbitrary web script or HTML via the "Primary button Text" or "Second button text" field.
CVE-2016-10872 1 Ultimatemember 1 Ultimate Member 2019-09-02 4.3 MEDIUM 6.1 MEDIUM
The ultimate-member plugin before 1.3.40 for WordPress has XSS on the login form.
CVE-2018-6944 1 Ultimatemember 1 Ultimate Member 2019-08-28 4.3 MEDIUM 6.1 MEDIUM
core/lib/upload/um-file-upload.php in the UltimateMember plugin 2.0 for WordPress has a cross-site scripting vulnerability because it fails to properly sanitize user input passed to the $temp variable.
CVE-2019-14946 1 Ultimatemember 1 Ultimate Member 2019-08-14 3.5 LOW 5.4 MEDIUM
The ultimate-member plugin before 2.0.52 for WordPress has XSS related to UM Roles create and edit operations.
CVE-2019-14945 1 Ultimatemember 1 Ultimate Member 2019-08-14 3.5 LOW 5.4 MEDIUM
The ultimate-member plugin before 2.0.54 for WordPress has XSS.
CVE-2019-14947 1 Ultimatemember 1 Ultimate Member 2019-08-14 3.5 LOW 5.4 MEDIUM
The ultimate-member plugin before 2.0.52 for WordPress has XSS during an account upgrade.