Vulnerabilities (CVE)

Filtered by vendor Ibm Subscribe
Filtered by product Guardium Data Encryption
Total 29 CVE
CVE Vendors Products Updated CVSS v2 CVSS v3
CVE-2021-39023 1 Ibm 1 Guardium Data Encryption 2022-05-16 5.0 MEDIUM 7.5 HIGH
IBM Guardium Data Encryption (GDE) 4.0.0 and 5.0.0 could allow a remote attacker to obtain sensitive information when a detailed technical error message is returned in the browser. This information could be used in further attacks against the system. IBM X-Force ID: 213860.
CVE-2021-39024 1 Ibm 1 Guardium Data Encryption 2022-05-16 4.3 MEDIUM 6.1 MEDIUM
IBM Guardium Data Encryption (GDE) 4.0.0.0 and 5.0.0.0 is vulnerable to cross-site scripting. This vulnerability allows users to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session. IBM X-Force ID: 213862.
CVE-2021-39027 1 Ibm 1 Guardium Data Encryption 2022-05-13 4.0 MEDIUM 5.0 MEDIUM
IBM Guardium Data Encryption (GDE) 4.0.0 and 5.0.0 prepares a structured message for communication with another component, but encoding or escaping of the data is either missing or done incorrectly. As a result, the intended structure of the message is not preserved. IBM X-Force ID: 213865.
CVE-2021-39020 1 Ibm 1 Guardium Data Encryption 2022-05-13 5.0 MEDIUM 5.3 MEDIUM
IBM Guardium Data Encryption (GDE) 4.0.0.7 and lower stores sensitive information in URL parameters. This may lead to information disclosure if unauthorized parties have access to the URLs via server logs, referrer header or browser history. IBM X-Force ID: 213855.
CVE-2021-39021 1 Ibm 1 Guardium Data Encryption 2022-03-24 5.0 MEDIUM 5.3 MEDIUM
IBM Guardium Data Encryption (GDE) 5.0.0.2 behaves differently or sends different responses under different circumstances in a way that is observable to an unauthorized actor, which could facilitate username enumeration. IBM X-Force ID: 213856.
CVE-2021-39022 1 Ibm 1 Guardium Data Encryption 2022-03-22 6.8 MEDIUM 8.8 HIGH
IBM Guardium Data Encryption (GDE) 4.0.0.0 and 5.0.0.0 saves user-provided information into a Comma-Separated Value (CSV) file, but it does not neutralize or incorrectly neutralizes special elements that could be interpreted as a command when the file is opened by spreadsheet software. IBM X-Force ID: 213858.
CVE-2021-39025 1 Ibm 1 Guardium Data Encryption 2022-03-18 5.0 MEDIUM 5.3 MEDIUM
IBM Guardium Data Encryption (GDE) 4.0.0.0 and 5.0.0.0 could disclose internal IP address information when the web backend is down. IBM X-Force 213863.
CVE-2021-39026 1 Ibm 1 Guardium Data Encryption 2022-02-25 4.3 MEDIUM 5.9 MEDIUM
IBM Guardium Data Encryption (GDE) 5.0.0.2 and 5.0.0.3 could allow a remote attacker to obtain sensitive information, caused by the failure to properly enable HTTP Strict Transport Security. An attacker could exploit this vulnerability to obtain sensitive information using man in the middle techniques. IBM X-Force ID: 213964.
CVE-2019-4692 1 Ibm 2 Guardium Data Encryption, Guardium For Cloud Key Management 2021-07-21 5.0 MEDIUM 5.3 MEDIUM
IBM Security Guardium Data Encryption (GDE) 3.0.0.2 discloses sensitive information to unauthorized users. The information can be used to mount further attacks on the system. IBM X-Force ID: 171829.
CVE-2019-4689 1 Ibm 2 Guardium Data Encryption, Guardium For Cloud Key Management 2021-07-21 5.0 MEDIUM 7.5 HIGH
IBM Security Guardium Data Encryption (GDE) 3.0.0.2 could allow a remote attacker to obtain sensitive information, caused by the failure to properly enable HTTP Strict Transport Security. An attacker could exploit this vulnerability to obtain sensitive information using man in the middle techniques. IBM X-Force ID: 171826.
CVE-2019-4686 1 Ibm 2 Guardium Data Encryption, Guardium For Cloud Key Management 2021-07-21 5.0 MEDIUM 5.3 MEDIUM
IBM Security Guardium Data Encryption (GDE) 3.0.0.2 does not set the secure attribute on authorization tokens or session cookies. Attackers may be able to get the cookie values by sending a http:// link to a user or by planting this link in a site the user goes to. The cookie will be sent to the insecure link and the attacker can then obtain the cookie value by snooping the traffic. IBM X-Force ID: 171822.
CVE-2019-4701 1 Ibm 2 Guardium Data Encryption, Guardium For Cloud Key Management 2021-07-21 5.0 MEDIUM 5.3 MEDIUM
IBM Security Guardium Data Encryption (GDE) 3.0.0.2 is deployed with active debugging code that can create unintended entry points. IBM X-Force ID: 171936.
CVE-2019-4713 1 Ibm 2 Guardium Data Encryption, Guardium For Cloud Key Management 2021-07-21 9.0 HIGH 8.8 HIGH
IBM Security Guardium Data Encryption (GDE) 3.0.0.2 could allow a remote authenticated attacker to execute arbitrary commands on the system. By sending a specially-crafted request, an attacker could exploit this vulnerability to execute arbitrary commands on the system. IBM X-Force ID: 172084.
CVE-2021-20414 1 Ibm 1 Guardium Data Encryption 2021-07-14 4.0 MEDIUM 4.9 MEDIUM
IBM Guardium Data Encryption (GDE) 3.0.0.2 could allow a user to bruce force sensitive information due to not properly limiting the number of interactions. IBM X-Force ID: 196216.
CVE-2021-20474 1 Ibm 1 Guardium Data Encryption 2021-07-12 5.0 MEDIUM 7.5 HIGH
IBM Guardium Data Encryption (GDE) 3.0.0.2 and 4.0.0.4 does not perform any authentication for functionality that requires a provable user identity or consumes a significant amount of resources.
CVE-2021-20415 1 Ibm 1 Guardium Data Encryption 2021-07-09 5.0 MEDIUM 7.5 HIGH
IBM Guardium Data Encryption (GDE) 4.0.0.4 uses an inadequate account lockout setting that could allow a remote attacker to brute force account credentials. IBM X-Force ID: 196217.
CVE-2021-20416 1 Ibm 1 Guardium Data Encryption 2021-07-09 5.0 MEDIUM 5.3 MEDIUM
IBM Guardium Data Encryption (GDE) 3.0.0.3 and 4.0.0.4 could allow a remote attacker to obtain sensitive information, caused by the failure to set the HTTPOnly flag. A remote attacker could exploit this vulnerability to obtain sensitive information from the cookie. IBM X-Force ID: 196218.
CVE-2021-20379 1 Ibm 1 Guardium Data Encryption 2021-07-09 5.0 MEDIUM 7.5 HIGH
IBM Guardium Data Encryption (GDE) 3.0.0.3 and 4.0.0.4 uses weaker than expected cryptographic algorithms that could allow an attacker to decrypt highly sensitive information. IBM X-Force ID: 195711.
CVE-2021-20417 1 Ibm 1 Guardium Data Encryption 2021-07-09 4.0 MEDIUM 4.3 MEDIUM
IBM Guardium Data Encryption (GDE) 4.0.0.4 could allow a remote attacker to obtain sensitive information when a detailed technical error message is returned in the browser. This information could be used in further attacks against the system. IBM X-Force ID: 196219
CVE-2021-20378 1 Ibm 1 Guardium Data Encryption 2021-07-09 6.5 MEDIUM 8.8 HIGH
IBM Guardium Data Encryption (GDE) 3.0.0.2 and 4.0.0.4 does not invalidate session after logout which could allow an authenticated user to impersonate another user on the system. IBM X-Force ID: 195709.